No need of debian/patches
[maemo-efl] / trunk / ecore / debian_gregale / rules
index 62e6481..afa6e59 100755 (executable)
@@ -2,7 +2,6 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
 
 DEB_CONFIGURE_EXTRA_FLAGS :=  --enable-ecore-evas-x11-16       \
                                                          --disable-ecore-fb                    \
@@ -21,6 +20,12 @@ DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 CFLAGS += -I/usr/X11R6/include
 
 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -mcpu=arm926ej-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
+               CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
+       endif
+       ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
+                CFLAGS += -mcpu=arm926ej-s
+       endif
 endif