don't patch sources during build
[marble] / packaging / debian / rules
index 98b9168..dda91d6 100755 (executable)
@@ -4,7 +4,22 @@
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/makefile.mk
 
-CMAKE = cmake -DCMAKE_INSTALL_PREFIX=$(CURDIR)/debian/tmp/opt/marble -DMARBLE_DATA_INSTALL_PATH=$(CURDIR)/debian/tmp/opt/marble/share/marble/data -DQTONLY=ON -DMARBLE_DATA_PATH=/opt/marble/share/marble/data -DMARBLE_PLUGIN_INSTALL_PATH=$(CURDIR)/debian/tmp/opt/marble/lib/marble/plugins -DMARBLE_PLUGIN_PATH=/opt/marble/lib/marble/plugins -DPACKAGE_ROOT_PREFIX=$(CURDIR)/debian/tmp -DCMAKE_SKIP_RPATH=ON -DBUILD_MARBLE_TESTS=OFF -DENABLE_TESTS=FALSE -DCMAKE_BUILD_TYPE=Release -DBUILD_INHIBIT_SCREENSAVER_PLUGIN=TRUE
+CMAKE = cmake -DCMAKE_INSTALL_PREFIX=$(CURDIR)/debian/tmp/opt/marble \
+              -DMARBLE_DATA_INSTALL_PATH=$(CURDIR)/debian/tmp/opt/marble/share/marble/data \
+              -DQTONLY=ON \
+              -DMARBLE_DATA_PATH=/opt/marble/share/marble/data \
+              -DMARBLE_PLUGIN_INSTALL_PATH=$(CURDIR)/debian/tmp/opt/marble/lib/marble/plugins \
+              -DMARBLE_PLUGIN_PATH=/opt/marble/lib/marble/plugins \
+              -DPACKAGE_ROOT_PREFIX=$(CURDIR)/debian/tmp \
+              -DCMAKE_SKIP_RPATH=ON \
+              -DBUILD_MARBLE_TESTS=OFF \
+              -DENABLE_TESTS=FALSE \
+              -DCMAKE_BUILD_TYPE=Release \
+              -DMOBILE=ON \
+              -DBUILD_INHIBIT_SCREENSAVER_PLUGIN=TRUE \
+              -DICON_INSTALL_DIR=$(CURDIR)/debian/tmp/usr/share/icons \
+              -DAPPS_INSTALL_DIR=$(CURDIR)/debian/tmp/usr/share/applications/hildon \
+              $(DEB_SRCDIR)
 
 DEB_MAKE_INSTALL_TARGET = install
 
@@ -66,8 +81,12 @@ clean::
 common-configure-arch::
        $(CMAKE)
 
-common-install-indep::
-       mv $(CURDIR)/debian/tmp/opt/marble/share/marble/data/placemarks/cityplacemarks{_large_population,}.cache
+common-install-arch::
+       install -D -m u+rw-x,g+r-wx,o+r-wx $(DEB_SRCDIR)/data/icons/hi32-app-marble.png $(CURDIR)/debian/tmp/usr/share/icons/hicolor/26x26/apps/marble.png
+       install -D -m u+rwx,g+rx-w,o+rx-w $(CURDIR)/debian/marble.sh $(CURDIR)/debian/tmp/opt/marble/bin/marble.sh
+       install -D -m u+rw-x,g+r-wx,o+r-wx $(CURDIR)/debian/marble.service $(CURDIR)/debian/tmp/usr/share/dbus-1/services/marble.service
+       install -D -m u+rw-x,g+r-wx,o+r-wx $(CURDIR)/debian/migration-warning.txt $(CURDIR)/debian/tmp/opt/marble/share/marble/data/migration-warning.txt
+       patch -p0 -d $(DEB_DH_INSTALL_SOURCEDIR) < $(CURDIR)/debian/maemo-launcher.diff
 
 common-binary-post-install-indep::
        rm -f $(CURDIR)/debian/marble-data/usr/share/marble/data/LICENSE.txt