Export Checkbox as separate qml file
[mdictionary] / debian / rules
index adc54e0..6b6af66 100755 (executable)
@@ -12,13 +12,14 @@ build: build-stamp
 build-stamp: configure-stamp
        dh_testdir
        $(MAKE)
+       $(MAKE) doc
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       if test -f $(CURDIR)/Makefile; then \
+       if test -f $(CURDIR)/Makefile ; then \
                $(MAKE) distclean; \
        fi
        dh_clean
@@ -28,14 +29,20 @@ install:
        dh_testroot
        dh_clean -k
        dh_installdirs
-       cd $(CURDIR)/src && $(MAKE) -j 4 INSTALL_ROOT=$(CURDIR)/debian/mdictionary install
+       INSTALL_ROOT=$(CURDIR)/debian/tmp $(MAKE) install
 
 binary-indep: build install
 
 binary-arch: install
-       dh_maemo_package_icons
        dh_testdir
        dh_testroot
+       if [ -e $(CURDIR)/debian/tmp/usr/share/applications/mdictionary.desktop ] ; then \
+               sed -i -e 's/.*mdictionary.desktop/usr\/share\/applications\/mdictionary.desktop/g' $(CURDIR)/debian/mdictionary.install ;\
+       else \
+               sed -i -e 's/.*mdictionary.desktop/usr\/share\/applications\/hildon\/mdictionary.desktop/g' $(CURDIR)/debian/mdictionary.install ;\
+       fi
+       dh_install --sourcedir=$(CURDIR)/debian/tmp
+       dh_installdocs
        dh_strip
        dh_compress
        dh_fixperms
@@ -44,7 +51,7 @@ binary-arch: install
        dh_gencontrol
        dh_md5sums
        dh_builddeb
-       dh_maemo_package_icons -r
+#      dh_maemo_package_icons -r
        
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure