fix bug with empty dictionary list. Add first version of WordListView (qml)
[mdictionary] / debian / rules
index b92048f..6b6af66 100755 (executable)
@@ -1,78 +1,57 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-APPNAME := mdictionary
-
-builddir:
-       mkdir -p builddir
-
-builddir/Makefile: builddir
-       cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
 
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       qmake-qt4
+       touch configure-stamp
 
 build: build-stamp
 
-build-stamp: builddir/Makefile
+build-stamp: configure-stamp
        dh_testdir
-       cd builddir && $(MAKE)
+       $(MAKE)
+       $(MAKE) doc
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp
-       rm -rf builddir
+       rm -f build-stamp configure-stamp
+       if test -f $(CURDIR)/Makefile ; then \
+               $(MAKE) distclean; \
+       fi
        dh_clean
 
-install: build
+install:
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs
-       cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
+       INSTALL_ROOT=$(CURDIR)/debian/tmp $(MAKE) install
 
-# Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-arch: install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
+       if [ -e $(CURDIR)/debian/tmp/usr/share/applications/mdictionary.desktop ] ; then \
+               sed -i -e 's/.*mdictionary.desktop/usr\/share\/applications\/mdictionary.desktop/g' $(CURDIR)/debian/mdictionary.install ;\
+       else \
+               sed -i -e 's/.*mdictionary.desktop/usr\/share\/applications\/hildon\/mdictionary.desktop/g' $(CURDIR)/debian/mdictionary.install ;\
+       fi
+       dh_install --sourcedir=$(CURDIR)/debian/tmp
        dh_installdocs
-       dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_python
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
-
+#      dh_maemo_package_icons -r
+       
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure