Update rev. # to r4 and move to Fremantle
[oespirit1] / libosso_2.16.bb
1 # Copyright (C) 2009 Kirtika B Ruchandani <kirtibr@gmail.com> 
2 # Released under the MIT license (see COPYING.MIT for the terms)
3 # NOTE: outo is now optional in libosso.
4 # libosso builds without outo. TO-DO- add outo recipes
5
6 DESCRIPTION = "Nokia OSSO IPC library"
7 HOMEPAGE = "http://maemo.org"
8 LICENSE = "GNU Lesser Public License-version 2.1"
9 SECTION = "base"
10 SECTION_${PN}-doc = "doc"
11 SECTION_${PN}-dev = "devel"
12
13 PR = "r1"
14
15
16 require libosso.inc
17
18
19 SRC_URI = " \
20             http://repository.maemo.org/pool/diablo/free/libo/${PN}/${PN}_${PV}-1.tar.gz \
21             file://gcc431.patch;patch=1 \
22           "
23
24 PACKAGES += "${PN}-outo ${PN}-outo-dev ${PN}-outo-dbg ${PN}-outo-bin-dbg ${PN}-outo-bin"
25
26 FILES_${PN}-outo = "${libdir}/outo/lib*.so"
27 FILES_${PN}-outo-dev = "${libdir}/outo/*.la ${libdir}/outo/*.a"
28 FILES_${PN}-outo-dbg = "${libdir}/outo/.debug/lib*.so"
29 FILES_${PN}-outo-bin-dbg = "${libdir}/outo/.debug/*bin"
30 FILES_${PN}-outo-bin = "${libdir}/outo/*bin ${libdir}/outo/mimedummy.doc"