97a0c7a540cd8ddc9d9959d2dbe1f11bcc4faa13
[monky] / app-admin / conky / conky-1.9999.ebuild
1 # CVS ebuild for Conky, thanks to Hopeless
2 # $Header$
3
4 ECVS_SERVER="cvs.sourceforge.net:/cvsroot/conky"
5 ECVS_MODULE="conky"
6 inherit cvs
7
8 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
9 HOMEPAGE="http://conky.sf.net"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
14 IUSE="truetype seti X"
15
16 RDEPEND="virtual/libc
17    X? ( virtual/x11 )
18    truetype? ( >=media-libs/freetype-2 )
19    seti? ( sci-astronomy/setiathome )
20    "
21
22 DEPEND="truetype? ( >=media-libs/freetype-2 )
23    X? ( virtual/x11 )
24    >=sys-devel/automake-1.9
25    >=sys-devel/autoconf-2.59
26    sys-devel/libtool
27    sys-apps/grep
28    sys-apps/sed
29    sys-devel/gcc
30    "
31
32 S=${WORKDIR}/conky
33
34 src_unpack() {
35         cvs_src_unpack
36         cd ${S}
37         NOCONFIGURE=blah ./autogen.sh
38 }
39
40 src_compile() {
41    econf \
42       $(use_enable truetype xft) \
43       $(use_enable seti) \
44           $(use_enable X x11) \
45       --enable-double-buffer \
46       --enable-own-window \
47       --enable-proc-uptime \
48           --enable-mpd \
49           --enable-mldonkey \
50       || die "econf failed"
51    emake || die "compile failed"
52 }
53
54 src_install() {
55    emake DESTDIR=${D} install || die "make install failed"
56    dodoc ChangeLog AUTHORS README conkyrc.sample
57 }
58
59 pkg_postinst() {
60    einfo 'default configuration file is "~/.conkyrc"'
61    einfo "you can find a sample configuration file in"
62    einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
63    einfo
64    einfo "For more info on Conky's new features,"
65    einfo "please look at the README and ChangeLog:"
66    einfo "/usr/share/doc/${PF}/README.gz"
67    einfo "/usr/share/doc/${PF}/ChangeLog.gz"
68    einfo
69    einfo "Comment out temperature info lines if you have no kernel"
70    einfo "support for it."
71    einfo
72    ewarn "Conky doesn't work with window managers that"
73    ewarn "take control over root window such as Gnome's nautilus."
74