Updgraded libhildonmime from diablo to fremantle
[oespirit1] / libhildonmime_2.1.3.bb
diff --git a/libhildonmime_2.1.3.bb b/libhildonmime_2.1.3.bb
new file mode 100644 (file)
index 0000000..26f9954
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright (C) 2009 Unknow User <unknow@user.org>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+
+DESCRIPTION = "Nokia Hildon mime library"
+HOMEPAGE = "http://maemo.org"
+LICENSE = "GNU Lesser General Public License-version 2.1"
+SECTION = "base"
+DEPENDS = "libosso gnome-vfs"
+PR = "r1"
+
+SRC_URI =  " http://repository.maemo.org/pool/fremantle/free/libh/${PN}/${PN}_${PV}-1+0m5.tar.gz \
+             file://libhildonmime/mer-changes.patch;patch=1 "
+
+EXTRA_OECONF += "--with-compile-warnings=no"
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+       # remove Werror from OSSO_CFLAGS
+       sed -i s:-Werror::g configure.in
+}
+
+do_stage() {
+       autotools_stage_all
+}