Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / ext / gio / Makefile.am
diff --git a/gst-plugins-base-subtitles0.10/ext/gio/Makefile.am b/gst-plugins-base-subtitles0.10/ext/gio/Makefile.am
new file mode 100644 (file)
index 0000000..f4b1611
--- /dev/null
@@ -0,0 +1,29 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstgio.la
+
+# sources used to compile this plug-in
+libgstgio_la_SOURCES = \
+               gstgio.c \
+               gstgiobasesink.c \
+               gstgiobasesrc.c \
+               gstgiosink.c \
+               gstgiosrc.c \
+               gstgiostreamsink.c \
+               gstgiostreamsrc.c
+
+libgstgio_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GIO_CFLAGS)
+libgstgio_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(GIO_LIBS)
+libgstgio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GIO_LDFLAGS)
+libgstgio_la_LIBTOOLFLAGS = --tag=disable-static
+
+# headers we need but don't want installed
+noinst_HEADERS = \
+               gstgio.h \
+               gstgiobasesink.h \
+               gstgiobasesrc.h \
+               gstgiosink.h \
+               gstgiosrc.h \
+               gstgiostreamsink.h \
+               gstgiostreamsrc.h
+