Uploaded initial version.
[guivpn] / trunk / vpngui / configure.ac
diff --git a/trunk/vpngui/configure.ac b/trunk/vpngui/configure.ac
new file mode 100644 (file)
index 0000000..2ff3a60
--- /dev/null
@@ -0,0 +1,83 @@
+AC_INIT([osso-statusbar-sync], [0.1])
+#AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+
+AM_CONFIG_HEADER([config.h])
+
+AC_PROG_CC
+AC_PROG_CPP
+#AC_PROG_INSTALL
+AC_PROG_CXX
+#AM_PROG_CC_STDC
+AC_PROG_LIBTOOL
+
+#AC_C_CONST
+#AC_HEADER_STDC
+AC_CHECK_HEADERS([libintl.h])
+
+GETTEXT_PACKAGE=$PACKAGE_NAME
+AC_SUBST(GETTEXT_PACKAGE)
+AM_GLIB_GNU_GETTEXT
+
+#FLAGS="$CXXFLAGS -Werror -Wall -Wcast-align -Wmissing-declarations"
+
+AC_ARG_ENABLE([debug], AS_HELP_STRING([--enable-debug],[Enable debug @<:@default=false@:>@]),
+  [case "${enableval}" in
+   yes) debug=true ; CFLAGS="-ggdb -O0 $CFLAGS" ;;
+   no)  debug=false ;;
+   *) AC_MSG_ERROR([bad value ${enableval} for --enable-debug]) ;;
+   esac],[debug=false])
+AM_CONDITIONAL([DEBUG], [test x$debug = xtrue])
+
+PKG_CHECK_MODULES(LIBHILDONDESKTOP,
+                  [libhildondesktop-1], 
+                  [AC_DEFINE(HAVE_LIBHILDONDESKTOP, [], [Whether libhildondesktop-1 is present on the system])], 
+                  [])
+AC_SUBST(LIBHILDONDESKTOP_LIBS)
+AC_SUBST(LIBHILDONDESKTOP_CFLAGS)
+
+PKG_CHECK_MODULES(CONIC, conic)
+AC_SUBST(CONIC_LIBS)
+AC_SUBST(CONIC_CFLAGS)
+
+#
+# FIXME: We only use the DBus definition header files from the libmaesync
+# package so we should not link with the shared object.
+#
+PKG_CHECK_MODULES([STATUSBAR_SYNC],[
+       gtk+-2.0 >= 2.10.1
+       hildon-1 >= 1.0.0
+       libosso >= 2.0
+       gconf-2.0 >= 2.16.0
+])
+AC_SUBST(STATUSBAR_SYNC_LIBS)
+AC_SUBST(STATUSBAR_SYNC_CFLAGS)
+
+pixmapsdir=${datadir}/pixmaps/hiro-vpn/
+AC_SUBST(pixmapsdir)
+hildonpixmapdir=`$PKG_CONFIG --variable=hildonpixmapdir hildon-base`
+AC_SUBST(hildonpixmapdir)
+
+hildondesktoplibdir=`pkg-config libhildondesktop-1 --variable=hildondesktoplibdir`
+AC_SUBST(hildondesktoplibdir)
+
+hildonstatusmenudesktopentrydir=`pkg-config libhildondesktop-1 --variable=hildonstatusmenudesktopentrydir`
+AC_SUBST(hildonstatusmenudesktopentrydir)
+
+#
+# The localisation with the gettext package.
+#
+localedir=/usr/share/locale
+GETTEXT_PACKAGE="vpngui"
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], "${GETTEXT_PACKAGE}", [Gettext package])
+ALL_LINGUAS="en_GB en_US"
+AC_SUBST(ALL_LINGUAS)
+AM_GLIB_GNU_GETTEXT
+
+AC_CONFIG_FILES([
+       Makefile
+       src/Makefile
+])
+
+AC_OUTPUT