Add ARM files
[dh-make-perl] / dev / arm / libarchive-zip-perl / libarchive-zip-perl-1.18 / debian / rules
diff --git a/dev/arm/libarchive-zip-perl/libarchive-zip-perl-1.18/debian/rules b/dev/arm/libarchive-zip-perl/libarchive-zip-perl-1.18/debian/rules
new file mode 100755 (executable)
index 0000000..8fe4e6a
--- /dev/null
@@ -0,0 +1,90 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+PERL=/usr/bin/perl
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       # Add here commands to configure the package.
+       $(PERL) Makefile.PL INSTALLDIRS=vendor
+
+       touch configure-stamp
+
+build: configure-stamp build-stamp
+build-stamp:
+       dh_testdir
+
+       # Add here commands to compile the package.
+       $(PERL) Makefile.PL
+       $(MAKE)
+
+       # Make sure it all seems to be working okay.
+       $(MAKE) test
+
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       rm -rf testdir extracted
+
+       # Add here commands to clean up after the build process.
+       -$(MAKE) clean
+
+       rm -f Makefile.old
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+
+       # Add here commands to install the package into debian/tmp
+       $(MAKE) install INSTALLDIRS=vendor PREFIX=$(CURDIR)/debian/libarchive-zip-perl/usr
+       rm -rf $(CURDIR)/debian/libarchive-zip-perl/usr/lib
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+#      dh_movefiles
+
+#      dh_installdebconf       
+       dh_installdocs
+       dh_installexamples
+#      dh_installmenu
+#      dh_installlogrotate
+#      dh_installemacsen
+#      dh_installpam
+#      dh_installmime
+#      dh_installinit
+#      dh_installcron
+       dh_installman
+#      dh_installinfo
+#      dh_undocumented
+       dh_installchangelogs Changes
+       dh_link
+#      dh_strip
+       dh_compress
+       dh_fixperms
+#      dh_makeshlibs
+       dh_installdeb
+       dh_perl
+#      dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure