Fixed build
[maemo-efl] / trunk / python-edje / debian / rules
index d238b96..8c041da 100755 (executable)
@@ -4,36 +4,37 @@ PYVER=2.5
 PYTHON=python$(PYVER)
 
 p_base=$(PYTHON)-edje
-p_dev =$(p_base)-dev
-
 d_base=debian/$(p_base)
-d_dev=debian/$(p_dev)
 
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
-ifeq ($(DEB_BUILD_ARCH),armel)
-    #CFLAGS="-Os -mthumb -mfloat-abi=softfp -Wall -Wstrict-prototypes"
-    CFLAGS+="-DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant"
+ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
+    CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+    ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
+        CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
+    endif
+    ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
+         CFLAGS += -mcpu=arm926ej-s
+    endif
 endif
 
-build: build-stamp 
+build: build-stamp
 build-stamp:
-       dh_testdir 
+       dh_testdir
        touch edje/edje.c_evas.pyx
-       CFLAGS=$(CFLAGS) $(PYTHON) setup.py build_ext build install --prefix /usr install_headers
-       for f in debian/*.edj.uue ; do uudecode $$f -o $${f%.*} ; done
+       CFLAGS="$(CFLAGS)" $(PYTHON) setup.py build_ext build install --prefix /usr install_headers
        touch build-stamp
 clean:
        dh_testdir
        dh_testroot
-       $(PYTHON) setup.py clean 
+       $(PYTHON) setup.py clean
        -rm -f build-stamp
        -rm -rf build dist python_edje.egg-info
        -rm -f edje/*.py[co]
        -rm -f *.py[co]
        -rm -f debian/*.edj
-       dh_clean 
-       
+       dh_clean
+
 install: build
        dh_testdir
        dh_testroot
@@ -48,7 +49,6 @@ binary-arch: install
        dh_testroot
        dh_install
        dh_strip
-       #dh_compress -p$(p_dev) -Xexamples -X.py
        dh_fixperms
        dh_makeshlibs
        dh_installdeb