Add ARM files
[dh-make-perl] / dev / arm / libarray-compare-perl / libarray-compare-perl-1.16 / debian / rules
diff --git a/dev/arm/libarray-compare-perl/libarray-compare-perl-1.16/debian/rules b/dev/arm/libarray-compare-perl/libarray-compare-perl-1.16/debian/rules
new file mode 100755 (executable)
index 0000000..a997e5b
--- /dev/null
@@ -0,0 +1,56 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatibility version to use.
+#export DH_COMPAT=4
+
+PACKAGE=$(shell dh_listpackages)
+
+ifndef PERL
+PERL = /usr/bin/perl
+endif
+
+build: build-stamp
+build-stamp:
+       dh_testdir
+       # Add here commands to compile the package.
+       $(PERL) Build.PL installdirs=vendor create_packlist=0
+       ./Build
+       ./Build test
+       touch $@
+
+clean:
+       dh_testdir
+       dh_testroot
+       dh_clean build-stamp install-stamp
+       [ ! -f Build ] || ./Build distclean
+
+install: install-stamp
+install-stamp: build-stamp
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       ./Build install destdir=$(CURDIR)/debian/$(PACKAGE)
+       #[ ! -d $(CURDIR)/debian/$(PACKAGE)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents --verbose $(CURDIR)/debian/$(PACKAGE)/usr/lib/perl5
+       touch $@
+
+binary-arch:;
+binary-indep: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installchangelogs Changes
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_perl
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure