0.1.0
[maegirls] / debian / tags / 0.1.0 / rules
diff --git a/debian/tags/0.1.0/rules b/debian/tags/0.1.0/rules
new file mode 100755 (executable)
index 0000000..8c3a748
--- /dev/null
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+
+#DEB_PYTHON_VERSIONS:=2.5
+DEB_PYTHON_SYSTEM=pysupport
+
+PYVERS = $(shell pyversions -vd)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
+
+cdbs_python_current_binary := $(shell pyversions -d)
+
+DEB_PYTHON_INSTALL_ARGS_ALL = --no-compile -O0 --install-layout=deb
+
+install/maegirls::
+       dh_install misc/maegirls.desktop usr/share/applications/hildon/
+       cp misc/maegirls-64x64.png debian/maegirls.png
+       dh_install debian/maegirls.png usr/share/icons/hicolor/64x64/apps/
+       rm -f debian/maegirls.png
+
+#clean/maegirls::
+#      rm -f debian/maegirls.png
+
+python-build-stamp-%:
+ifeq (all, $(cdbs_python_module_arch))
+        cd $(DEB_SRCDIR) && $(cdbs_python_current_binary) $(DEB_PYTHON_SETUP_CMD) build $(DEB_PYTHON_BUILD_ARGS)
+else
+        cd $(DEB_SRCDIR) && $(cdbs_python_current_binary) $(DEB_PYTHON_SETUP_CMD) build $(DEB_PYTHON_BUILD_ARGS)
+endif # archall detection
+        touch $@
+
+# install stage
+ifeq (all, $(cdbs_python_module_arch))
+common-install-arch common-install-indep:: python-install-py
+python-install-py:
+        cd $(DEB_SRCDIR) && $(cdbs_python_current_binary) $(DEB_PYTHON_SETUP_CMD) install --root=$(DEB_DESTDIR) $(DEB_PYTHON_INSTALL_ARGS_ALL)
+else
+common-install-arch common-install-indep:: $(addprefix python-install-, $(cdbs_python_build_versions))
+python-install-%:
+        cd $(DEB_SRCDIR) && $(cdbs_python_current_binary) $(DEB_PYTHON_SETUP_CMD) install --root=$(DEB_DESTDIR) $(DEB_PYTHON_INSTALL_ARGS_ALL)
+endif # archall detection
+