tsst
[skippy-xd] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..cb5f602
--- /dev/null
@@ -0,0 +1,114 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0
+else
+       CFLAGS += -O2
+endif
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       # Add here commands to configure the package.
+
+       touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp  
+       dh_testdir
+
+       # Add here commands to compile the package.
+       $(MAKE)
+       #docbook-to-man debian/skippy-xd.sgml > skippy-xd.1
+
+       touch $@
+
+clean: 
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+
+       # Add here commands to clean up after the build process.
+       $(MAKE) clean
+
+       dh_clean 
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k 
+       dh_installdirs
+
+       # Add here commands to install the package into debian/skippy-xd.
+       $(MAKE) DESTDIR=$(CURDIR)/debian/skippy-xd install
+
+#      dh_installdirs
+       mkdir -p $(CURDIR)/debian/skippy-xd/usr/share/skippy-xd
+       mkdir -p $(CURDIR)/debian/skippy-xd/etc/init.d/
+       mkdir -p $(CURDIR)/debian/skippy-xd/home/user
+       mkdir -p $(CURDIR)/debian/skippy-xd/DEBIAN
+
+       cp -Ra $(CURDIR)/skippy-xd.rc-default \
+               $(CURDIR)/debian/skippy-xd/home/user/.skippy-xd.rc
+       cp -a $(CURDIR)/skippy-bg* \
+               $(CURDIR)/debian/skippy-xd/usr/share/skippy-xd/
+       cp -a $(CURDIR)/skippy-xd_maemo.init.sh \
+               $(CURDIR)/debian/skippy-xd/etc/init.d/skippy-xd_maemo
+       chown user:users  $(CURDIR)/debian/skippy-xd/home/user/.skippy-xd.rc
+#      chmod 666 $(CURDIR)/debian/skippy-xd/home/user/.skippy-xd.rc
+       chmod +x  $(CURDIR)/debian/skippy-xd/etc/init.d/skippy-xd_maemo
+       cp -a  $(CURDIR)/debian/skippy-xd.control $(CURDIR)/debian/skippy-xd/DEBIAN/control
+       cp -a  $(CURDIR)/debian/compat $(CURDIR)/debian/skippy-xd/DEBIAN/
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+#      dh_installchangelogs CHANGELOG
+#      dh_installdocs
+#      dh_installexamples
+#      dh_install
+#      dh_installmenu
+#      dh_installdebconf       
+#      dh_installlogrotate
+#      dh_installemacsen
+#      dh_installpam
+#      dh_installmime
+#      dh_python
+#      dh_installinit
+#      dh_installcron
+#      dh_installinfo
+#      dh_installman
+       dh_link
+       dh_strip
+#      dh_compress
+       dh_fixperms
+#      dh_perl
+#      dh_makeshlibs
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure