Merge branch 'master' into harmattan
[busybox-power] / debian / patches / 05thumb.patch
index b5e32c3..86a671e 100644 (file)
@@ -1,17 +1,11 @@
-Allow thumb flag to be passed to make (e.g. -mthumb)
-By Yauheni Kaliuta <yauheni.kaliuta@nokia.com>
-
-Ported to BusyBox 1.18.4 by Dennis Groenen <dennis_groenen@hotmail.com> - 2011-04-29  
----
-
 --- a/Makefile.flags
 +++ b/Makefile.flags
-@@ -51,7 +51,7 @@ CFLAGS += $(call cc-option,-fno-builtin-
+@@ -52,7 +52,7 @@ CFLAGS += $(call cc-option,-fno-builtin-
  # of branch probabilities (hopefully makes bloatcheck more stable):
  CFLAGS += $(call cc-option,-fno-guess-branch-probability,)
  CFLAGS += $(call cc-option,-funsigned-char -static-libgcc,)
 -CFLAGS += $(call cc-option,-falign-functions=1 -falign-jumps=1 -falign-labels=1 -falign-loops=1,)
 +CFLAGS += $(call cc-option,-falign-functions=1 -falign-jumps=1 -falign-labels=1 -falign-loops=1 $(THUMB),)
- # FIXME: These warnings are at least partially to be concerned about and should
- # be fixed..
+ # Defeat .eh_frame bloat (gcc 4.6.3 x86-32 defconfig: 20% smaller busybox binary):
+ CFLAGS += $(call cc-option,-fno-unwind-tables,)
+ CFLAGS += $(call cc-option,-fno-asynchronous-unwind-tables,)